Author Topic: Hugin GUI does not launch anymore after Java update  (Read 12125 times)

Offline ab

  • Newbie
  • *
  • Posts: 11
    • View Profile
Hugin GUI does not launch anymore after Java update
« on: April 10, 2008, 23:31:32 »
Dear all
I am using Hugin Researcher 6.4 on a Mac PowerBook G4 using Mac OS X Version 10.4.10. Recently, I updated the Java 2 Runtime Environment to 1.5.0_07. But since then, the Hugin GUI does not launch any more. Actually, I get the error message 'java.lang.UnsatisfiedLinkError: no hapi64 in java.library.path'. I tried to fix the problem in the X11 console, using commands like 'java -classpath <PATH>'; unfortunately, without success. Can anybody tell me how to fix the java path settings?
Any help is appreciated.
Many thanks in advance.
Alex

Offline Martin

  • HUGIN Expert
  • Hero Member
  • *****
  • Posts: 613
    • View Profile
Re: Hugin GUI does not launch anymore after Java update
« Reply #1 on: April 14, 2008, 12:54:20 »
Hello

I suspect that this is the same problem (no. 2) as described here:
http://forum.hugin.com/index.php?topic=56.0

The java.library.path property is not defined by the classpath, but instead by a parameter passed to java on the command line: -Djava.library.path=<path to library directory>

Try to add -Djava.library.path=bin to the 'java ...' command line and see if that helps.

Hugin Expert A/S

Offline ab

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Hugin GUI does not launch anymore after Java update
« Reply #2 on: April 14, 2008, 20:38:59 »
Thanks a lot for the reply. I tried the proposed commands but, unfortunately, the Hugin GUI still does not launch. I still get the same error (which, by the way, also occurs during API programming in eclipse).
I also tried to add shortcuts in folders of the actual Java version. But this didn't fix the problem either.

My actual Java version is:
java version "1.5.0_07"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_07-164)
Java HotSpot(TM) Client VM (build 1.5.0_07-87, mixed mode, sharing)


Could it be that my current Hugin distribution is somehow incompatible with that Java version? Finally, I also tried to run again the Hugin installation .pkg, which went smoothly. But when launching the Hugin 6.6.app in the /Applications-folder, the same error comes up again.

Offline ab

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Hugin GUI does not launch anymore after Java update
« Reply #3 on: April 15, 2008, 15:34:40 »
Hello, me again.

I tried again. I installed an up to date Hugin Researcher 6.9 distribution from my Institution. I installed the program in the folder /Applications/Hugin69. This created a 'Hugin 6.9.app' and a 'HDE6.7' folder. When I launch the 'Hugin 6.9.app' file, I still get the error-messagebox:
Exception in thread "main" java.lang.UnsatisfiedLinkError: no hapi64 in java.library.path

It is strange that it keeps searching for a hapi64-file.

I then tried to force the launch of the current Hugin version using:
java -Djava.library.path=/Applications/Hugin69/HDE6.7/Classes/hapi67.jar -jar /Applications/Hugin69/Hugin\ 6.9.app/Contents/Resources/Java/hgui.jar

But the error still is:
Exception in thread "main" java.lang.UnsatisfiedLinkError: no hapi64 in java.library.path
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1682)
        at java.lang.Runtime.loadLibrary0(Runtime.java:822)
        at java.lang.System.loadLibrary(System.java:992)
        at COM.hugin.HAPI.Native.DefaultNativeHAPI.loadLibrary(DefaultNativeHAPI.java:29)
        at COM.hugin.HAPI.Native.AbstractNativeHAPI.<init>(AbstractNativeHAPI.java:35)
        at COM.hugin.HAPI.Native.DefaultNativeHAPI.<init>(DefaultNativeHAPI.java:25)
        at COM.hugin.HAPI.Native.HAPI.<clinit>(HAPI.java:32)
        at COM.hugin.HAPI.ClassCollection.<init>(ClassCollection.java:59)
        at COM.hugin.HGUI.HuginGUIFrame.initializeGUIFrame(HuginGUIFrame.java:610)
        at COM.hugin.HGUI.HuginGUIFrame.<init>(HuginGUIFrame.java:207)
        at COM.hugin.HGUI.Hugin.<init>(Hugin.java:69)
        at COM.hugin.HGUI.Hugin.main(Hugin.java:254)


When I try to use the former 1.4.2 Java version using
/system/Library/Frameworks/JavaVM.framework/Versions/1.4.2/Commands/java -Djava.library.path=/Applications/Hugin69/HDE6.7/Classes/hapi67.jar -jar /Applications/Hugin69/Hugin\ 6.9.app/Contents/Resources/Java/hgui.jar

I get the following error
Exception in thread "main" java.lang.UnsupportedClassVersionError: COM/hugin/HGUI/Hugin (Unsupported major.minor version 49.0)
        at java.lang.ClassLoader.defineClass0(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
        at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)

This is really intriguing. - Is there yet something else I could try?
Any help is appreciated. Thanks a lot in advance.
Alex



Offline ab

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Hugin GUI does not launch anymore after Java update
« Reply #4 on: April 15, 2008, 22:19:44 »
I just solved my problem. In the folder /System/Library/Java/Extensions I had a (probably old) hapi64.jar file. I deleted this file from that location. Now, the Hugin 6.9 GUI launches perfectly...