Author Topic: After update align_image_stack just exits with no output  (Read 3055 times)

Offline hurleyman77

  • Newbie
  • *
  • Posts: 1
    • View Profile
After update align_image_stack just exits with no output
« on: September 22, 2018, 21:26:21 »
I have a Python script I've been using to experiment with automating something. Up to now, the following lines worked just fine:

Code: [Select]
final_command = "D:/Hugin/bin/align_image_stack -a "+results_directory+" -v -v -t 3 -g 5 -m -d -i -x -y -z --corr=0.85 -c 5000 "+temp_directory+"*.jpg"
print("executing", final_command)

Before, align_image_stack would run, write to the terminal, and align images (with varying degrees of success, but that's another matter). Then I noticed there was a more recent version so I downloaded the .msi (I'm on Windows) and installed it to the same directory. Manually typing and running the result "final_command" also worked just fine.

Now, when these lines execute, align_image_stack seems to launch, but writes nothing to the screen, produces no output, aligns no images. I've tried uninstalling and reinstalling, but no luck. This is also true when I just execute align_image_stack from a terminal, without going through the script at all.

Even with "-v -v" I get zero feedback from align_image_stack so I don't really have any way to even troubleshoot what's going on. I attempted performing a similar operation (stacking many nearly identical images) through the GUI without success. But this task has always proved impenetrable with Hugin, so I'm not sure that's useful as diagnostic data.

I was just beginning to have some success stacking lots of images! Any suggestions?